[C#] 오류. 엑셀 모듈 사용시 Microsoft.Office.Interop.Excel 지정된 파일을 찾을 수 없습니다.


닷넷 2.0 버전으로 개발한 프로그램을 4.0으로 업그레이드 하고 엑셀 모듈 사용하는 곳에서 오류가 발생 한다.

몇몇 자리만 그렇다.


System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.Interop.Excel, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. 지정된 파일을 찾을 수 없습니다.


기존의 Microsoft.Office.Interop.Excel 참조가 10 버전을 참조 했는데 4.0으로 솔루션 변환 하면서 14 버전으로 변경 된것 같다.

다시 10 버전으로 참조를 바꾸면 되지만 상황이 다시 빌드는 할수 없는 상황이다.


14 버전을 GAC에 등록해 주면 되는데 cmd에서 gacutil을 실행하면 2.0 버전으로 실행 된다. 

4.0 버전의 gacutil을 얻으려면 SDK를 설치 해야 한다. 각 자리에 SDK를 설치하긴 뭐하니까 따로 복사해주자.



gacutil4.zip



첨부 파일엔 4.0버전의 gacutil과 Microsoft.Office.Interop.Excel.dll, Office.dll 14버전이 있다.

2개의 dll을 GAC에 설치 해 주자.


gacutil /i Microsoft.Office.Interop.Excel.dll

gacutil /i Office.dll 


Trackbacks 0 / Comments 0

티스토리 툴바