[스프링 부트] 오류 : One or more constraints have not been satisfied

스프링 부트 학습을 위해서 이클립스 깔고 문서대로 했는데 아래와 같은 오류 발생

* One or more constraints have not been satisfied.

* Dynamic Web Module 3.1 requires Java 1.7 or newer.


* 해결방법

# Project > Properties > Java compiler

- compiler compliance level : 1.8 설정 

# Project > Project Facet

- Java : 1.8 설정 

# Window > Preferences > Java > Installed JREs 

- jdk 위치 1.8 설정 

# pom.xml 아래 내용 추가 

<properties>

<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>

<java.version>1.8</java.version>

</properties>

# Maven > Update Project


저작자 표시 비영리 변경 금지
신고

Trackbacks 0 / Comments 0

티스토리 툴바